Portable.BouncyCastle 1.8.0-beta4

BouncyCastle.Crypto is a cryptography API providing: -Generation and parsing of PKCS#12 files. -X.509: Generators and parsers for V1 and V3 certificates, V2 CRLs and attribute certificates. -PBE algorithms supported by PBEUtil: PBEwithMD2andDES-CBC, PBEwithMD2andRC2-CBC, PBEwithMD5andDES-CBC, PBEwithMD5andRC2-CBC, PBEwithSHA1andDES-CBC, PBEwithSHA1andRC2-CBC, PBEwithSHA-1and128bitRC4, PBEwithSHA-1and40bitRC4, PBEwithSHA-1and3-keyDESEDE-CBC, PBEwithSHA-1and2-keyDESEDE-CBC, PBEwithSHA-1and128bitRC2-CBC, PBEwithSHA-1and40bitRC2-CBC, PBEwithHmacSHA-1, PBEwithHmacSHA-224, PBEwithHmacSHA-256, PBEwithHmacRIPEMD128, PBEwithHmacRIPEMD160, and PBEwithHmacRIPEMD256. -Signature algorithms supported by SignerUtilities: MD2withRSA, MD4withRSA, MD5withRSA, RIPEMD128withRSA, RIPEMD160withRSA, RIPEMD256withRSA, SHA-1withRSA, SHA-224withRSA, SHA-256withRSAandMGF1, SHA-384withRSAandMGF1, SHA-512withRSAandMGF1, SHA-1withDSA, and SHA-1withECDSA. -Symmetric key algorithms: AES, Blowfish, Camellia, CAST5, CAST6, DESede, DES, GOST28147, HC-128, HC-256, IDEA, NaccacheStern, RC2, RC4, RC5-32, RC5-64, RC6, Rijndael, Serpent, Skipjack, TEA/XTEA, Twofish, and VMPC. -Symmetric key modes: CBC, CFB, CTS, GOFB, OFB, OpenPGPCFB, and SIC (or CTR). -Symmetric key paddings: ISO10126d2, ISO7816d4, PKCS#5/7, TBC, X.923, and Zero Byte. -Asymmetric key algorithms: RSA (with blinding), ElGamal, DSA, ECDSA. -Asymmetric key paddings/encodings: ISO9796d1, OAEP, and PKCS#1. -Digests: GOST3411, MD2, MD4, MD5, RIPEMD128, RIPEMD160, RIPEMD256, RIPEMD320, SHA-1, SHA-224, SHA-256, SHA-384, SHA-512, Tiger, and Whirlpool. -Signer mechanisms: DSA, ECDSA, ECGOST3410, GOST3410, ISO9796d2, PSS, RSA. -Key Agreement: Diffie-Hellman and EC-DH. -Macs: CBCBlockCipher, CFBBlockCipher, GOST28147, HMac, and ISO9797 Alg. 3. -PBE generators: PKCS#12, and PKCS#5 - schemes 1 and 2. -OpenPGP (RFC 2440) -Cryptographic Message Syntax (CMS, RFC 3852), including streaming API. -Online Certificate Status Protocol (OCSP, RFC 2560). -Time Stamp Protocol (TSP, RFC 3161). -TLS/SSL Client with support for client side authentication. Support for .NET 4, Windows Phone 8, Windows Phone App 8.1, Windows 8, Silverlight 5, MonoTouch, MonoAndroid

Showing the top 20 packages that depend on Portable.BouncyCastle.

Packages Downloads
OpenIddict
Versatile OpenID Connect stack for .NET. Note: this metapackage only references the generic core, server and validation packages. To use these features on ASP.NET Core or OWIN/Katana/ASP.NET 4.x, reference the OpenIddict.AspNetCore or OpenIddict.Owin package.
135
OpenIddict.Client
OpenIddict authorization client services. Note: this package only contains the generic/host-agnostic client components. To use the client feature on ASP.NET Core or OWIN/Katana, reference the OpenIddict.Client.AspNetCore or OpenIddict.Client.Owin package.
135
OpenIddict.Client
OpenIddict authorization client services. Note: this package only contains the generic/host-agnostic client components. To use the client feature on ASP.NET Core or OWIN/Katana, reference the OpenIddict.Client.AspNetCore or OpenIddict.Client.Owin package.
157
OpenIddict.Core
OpenIddict's core components, used to manage the applications, authorizations, scopes and tokens stored in the database.
136
OpenIddict.Core
OpenIddict's core components, used to manage the applications, authorizations, scopes and tokens stored in the database.
139
OpenIddict.Core
OpenIddict's core components, used to manage the applications, authorizations, scopes and tokens stored in the database.
140
OpenIddict.Core
OpenIddict's core components, used to manage the applications, authorizations, scopes and tokens stored in the database.
141
OpenIddict.Core
OpenIddict's core components, used to manage the applications, authorizations, scopes and tokens stored in the database.
142
OpenIddict.Core
OpenIddict's core components, used to manage the applications, authorizations, scopes and tokens stored in the database.
149
OpenIddict.Core
OpenIddict's core components, used to manage the applications, authorizations, scopes and tokens stored in the database.
154
OpenIddict.Server
OpenIddict authorization server services. Note: this package only contains the generic/host-agnostic server components. To use the server feature on ASP.NET Core or OWIN/Katana, reference the OpenIddict.Server.AspNetCore or OpenIddict.Server.Owin package.
136
OpenIddict.Server
OpenIddict authorization server services. Note: this package only contains the generic/host-agnostic server components. To use the server feature on ASP.NET Core or OWIN/Katana, reference the OpenIddict.Server.AspNetCore or OpenIddict.Server.Owin package.
137
OpenIddict.Server
OpenIddict authorization server services. Note: this package only contains the generic/host-agnostic server components. To use the server feature on ASP.NET Core or OWIN/Katana, reference the OpenIddict.Server.AspNetCore or OpenIddict.Server.Owin package.
139
OpenIddict.Server
OpenIddict authorization server services. Note: this package only contains the generic/host-agnostic server components. To use the server feature on ASP.NET Core or OWIN/Katana, reference the OpenIddict.Server.AspNetCore or OpenIddict.Server.Owin package.
144
OpenIddict.Server
OpenIddict authorization server services. Note: this package only contains the generic/host-agnostic server components. To use the server feature on ASP.NET Core or OWIN/Katana, reference the OpenIddict.Server.AspNetCore or OpenIddict.Server.Owin package.
151
OpenIddict.Server
OpenIddict authorization server services. Note: this package only contains the generic/host-agnostic server components. To use the server feature on ASP.NET Core or OWIN/Katana, reference the OpenIddict.Server.AspNetCore or OpenIddict.Server.Owin package.
155
OpenIddict.Server
OpenIddict authorization server services. Note: this package only contains the generic/host-agnostic server components. To use the server feature on ASP.NET Core or OWIN/Katana, reference the OpenIddict.Server.AspNetCore or OpenIddict.Server.Owin package.
169
OpenIddict.Server
OpenIddict authorization server services. Note: this package only contains the generic/host-agnostic server components. To use the server feature on ASP.NET Core or OWIN/Katana, reference the OpenIddict.Server.AspNetCore or OpenIddict.Server.Owin package.
203
OpenIddict.Server.AspNetCore
ASP.NET Core integration package for the OpenIddict server services.
140

This package has no dependencies.

Version Downloads Last updated
1.9.0 147 04/01/2025
1.8.10 137 04/01/2025
1.8.9 129 04/01/2025
1.8.8 117 04/01/2025
1.8.6.7 139 04/01/2025
1.8.6 147 04/01/2025
1.8.5.2 176 04/01/2025
1.8.5 125 04/01/2025
1.8.4 117 04/01/2025
1.8.3.37 131 04/01/2025
1.8.3 128 04/01/2025
1.8.2 149 04/01/2025
1.8.1.4 174 04/01/2025
1.8.1.3 120 04/01/2025
1.8.1.2 141 04/01/2025
1.8.1.1 120 04/01/2025
1.8.1 123 04/01/2025
1.8.0 124 04/01/2025
1.8.0-rc4 135 04/01/2025
1.8.0-rc3 113 04/01/2025
1.8.0-rc2 129 04/01/2025
1.8.0-RC1 127 04/01/2025
1.8.0-beta4-update1 147 04/01/2025
1.8.0-beta4 135 04/01/2025
1.8.0-beta3 123 04/01/2025
1.7.0.2 131 04/01/2025
1.7.0.1 128 04/01/2025
1.7.0 120 04/01/2025